Code

Opened 7 years ago

Closed 7 years ago

#3537 closed (duplicate)

Django try to format initial sql string if they contains % character

Reported by: bluszcz@… Owned by: adrian
Component: Core (Management commands) Version: 0.95
Severity: Keywords: syncdb
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If custom sql from sql directory (initial data) contains character % like below:

RAISE EXCEPTION 'Invalid name: [%]', NEW.name;

django syncdb crash.

Little fix is attached.

Attachments (1)

do_not_format_string.diff (563 bytes) - added by bluszcz@… 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by bluszcz@…

comment:1 Changed 7 years ago by SmileyChris

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed

comment:2 Changed 7 years ago by Craig Ogg <cogg@…>

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3485

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.