Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#35351 closed Bug (invalid)

"RuntimeError: Event loop is closed" when using aiomysql with Django async views

Reported by: Owais Ahmed Owned by: nobody
Component: Database layer (models, ORM) Version: 5.0
Severity: Normal Keywords:
Cc: Owais Ahmed Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I am getting same issue as this guy in StackOverflow https://stackoverflow.com/questions/78165096/flask-with-aiomysql-runtime-error-event-loop-closed
only difference is that he is using flask and I am using Django. First request works fine and data is stored to db but then for all the requests I am getting event loop closed error.
Can anyone help me here please.

Change History (2)

comment:1 by Natalia Bidart, 4 months ago

Resolution: invalid
Status: newclosed

Hello,

This ticket seems better suited to be a support request. The best place to get answers to your issue is using any of the user support channels from this link.

Since the goal of this issue tracker is to track issues about Django itself, and your issue seems, at first, to be located in your custom code, I'll be closing this ticket as invalid following the ticket triaging process. If, after debugging, you find out that this is indeed a bug in Django, please re-open with the specific details and please be sure to include a small Django project to reproduce or a failing test case.

Thank you!

comment:2 by Natalia Bidart, 4 months ago

Summary: Getting event loop closed error when using aiomysql with Django async views"RuntimeError: Event loop is closed" when using aiomysql with Django async views
Note: See TracTickets for help on using tickets.
Back to Top