Opened 3 months ago

Closed 3 months ago

#35004 closed Bug (fixed)

Arrows between "selector available" and "selector chosen" are backwards for RTL languages

Reported by: Natalia Bidart Owned by: Mariusz Felisiak
Component: contrib.admin Version: dev
Severity: Normal Keywords: rtl
Cc: Tom Carrick, Shai Berger, Nick Pope Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: yes

Description

While reviewing and debugging the PR for ticket #34995, I've noticed that the arrows to move objects between "selector available" and "selector chosen" (in M2M relationships) point to the wrong side for RTL laguages in "tablet size" screens. See screenshots attached.

Attachments (4)

django-admin-wrong-arrow-direction-rtl.png (73.3 KB ) - added by Natalia Bidart 3 months ago.
Example in Django 4.2
django-admin-wrong-arrow-direction-rtl-5.0.png (45.8 KB ) - added by Natalia Bidart 3 months ago.
Example in Django 5.0
django-admin-wrong-arrow-rtl-before.png (59.7 KB ) - added by Natalia Bidart 3 months ago.
Arrows in small screen for RTL lang before 57c1dd466f
django-admin-wrong-arrow-rtl-after.png (56.9 KB ) - added by Natalia Bidart 3 months ago.
Arrows in small screen for RTL lang after 57c1dd466f

Download all attachments as: .zip

Change History (15)

by Natalia Bidart, 3 months ago

Example in Django 4.2

by Natalia Bidart, 3 months ago

Example in Django 5.0

comment:1 by Natalia Bidart, 3 months ago

Cc: Tom Carrick added
Severity: Release blockerNormal
Version: 4.2dev

Removing status of Release Blocker since the issue is also present in 4.1.

comment:2 by Mariusz Felisiak, 3 months ago

Owner: changed from nobody to Mariusz Felisiak
Status: newassigned
Triage Stage: UnreviewedAccepted

comment:3 by Mariusz Felisiak, 3 months ago

Summary: Admin: arrows between "selector available" and "selector chosen" are backwards for RTL languagesArrows between "selector available" and "selector chosen" are backwards for RTL languages

comment:4 by Mariusz Felisiak, 3 months ago

Cc: Shai Berger added
Has patch: set

comment:5 by GitHub <noreply@…>, 3 months ago

Resolution: fixed
Status: assignedclosed

In 57c1dd4:

Fixed #35004 -- Corrected the direction of arrows in admin selector boxes for RTL languages on small screens.

Follow up to 12617fbd859b1244e91bcf182a2fdf356b388821.

by Natalia Bidart, 3 months ago

Arrows in small screen for RTL lang before 57c1dd466f

by Natalia Bidart, 3 months ago

Arrows in small screen for RTL lang after 57c1dd466f

comment:6 by Natalia Bidart, 3 months ago

Cc: Nick Pope added
Resolution: fixed
Status: closednew

Mariusz, while the PR does fix the arrow direction in "medium" screens (tablet size for example), they are now weird in small screens (like phones, see screenshots). Before this change, the arrows would be "up and down" for small screen, and now they are "side to side" when the widgets are one on top of the arrows and the other below the arrows.

  • Before 57c1dd466f change:

Arrows in small screen for RTL lang before 57c1dd466f

  • After 57c1dd466f change:

Arrows in small screen for RTL lang after 57c1dd466f

comment:7 by Natalia Bidart, 3 months ago

Has patch: unset

comment:8 by Mariusz Felisiak, 3 months ago

Good catch, will work on it tomorrow.

comment:9 by Mariusz Felisiak, 3 months ago

Has patch: set

comment:10 by GitHub <noreply@…>, 3 months ago

In dafbed9a:

Refs #35004 -- Restored the direction of arrows in admin selector boxes for RTL languages on mobile screens.

Regression in 57c1dd466ff0d41760049d6818e82be9d767c7da.

comment:11 by Mariusz Felisiak, 3 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.
Back to Top