Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#34638 closed Bug (fixed)

Rows are selected if BooleanField is in list_editable

Reported by: Andrei Shabanski Owned by: Neeraj Kumar
Component: contrib.admin Version: 4.2
Severity: Release blocker Keywords:
Cc: Neeraj Kumar, Marcelo Galigniana, Carlton Gibson Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: yes

Description (last modified by David Sanders)

If BooleanField is list_ediable and it stores True, the row will be highlighted on the changelist view. That row isn't selected for bulk actions though.

https://i.imgur.com/4zxrKSe.png

Ref #33491

Change History (14)

comment:1 by Andrei Shabanski, 14 months ago

Description: modified (diff)

comment:2 by Andrei Shabanski, 14 months ago

Description: modified (diff)

comment:3 by Neeraj Kumar, 14 months ago

Cc: Neeraj Kumar added
Owner: changed from nobody to Neeraj Kumar
Status: newassigned

comment:4 by Neeraj Kumar, 14 months ago

Description: modified (diff)
Has patch: set

comment:6 by David Sanders, 14 months ago

Triage Stage: UnreviewedAccepted

Thanks for the report 👍

comment:7 by David Sanders, 14 months ago

Cc: Marcelo Galigniana Carlton Gibson added
Severity: NormalRelease blocker

comment:8 by David Sanders, 14 months ago

Description: modified (diff)

Neeraj it's not necessary to add PR links in the description as well as your comment ;)

PRs are automatically linked (see the "Pull Requests:" bit at the top). Some people like to see PRs in the comments too 🤷‍♂️ But I'd leave it out of the description as it looks like the reporter added it.

comment:9 by Neeraj Kumar, 14 months ago

PR link in the description was added by mistake. ☻

Last edited 14 months ago by Neeraj Kumar (previous) (diff)

comment:10 by Mariusz Felisiak, 14 months ago

Needs documentation: set
Patch needs improvement: set

comment:11 by Mariusz Felisiak, 14 months ago

Needs documentation: unset
Patch needs improvement: unset

comment:12 by Mariusz Felisiak, 14 months ago

Triage Stage: AcceptedReady for checkin

comment:13 by Mariusz Felisiak <felisiak.mariusz@…>, 14 months ago

Resolution: fixed
Status: assignedclosed

In 1d9d3238:

Fixed #34638 -- Fixed admin change list selected row highlight on editable boolean fields.

Regression in 0aa2f16e63887d6053f6fd0da19254fc74c750ae.

Thanks Andrei Shabanski for the report.

comment:14 by Mariusz Felisiak <felisiak.mariusz@…>, 14 months ago

In 9e9a286b:

[4.2.x] Fixed #34638 -- Fixed admin change list selected row highlight on editable boolean fields.

Regression in 0aa2f16e63887d6053f6fd0da19254fc74c750ae.

Thanks Andrei Shabanski for the report.

Backport of 1d9d32389c652edc56ada65116d39789896f4820 from main.

Note: See TracTickets for help on using tickets.
Back to Top