Code

Opened 7 years ago

Closed 7 years ago

#3386 closed (duplicate)

add PYTHONSTARTUP capability to manage.py shell

Reported by: Jeff Bauer <jbauer@…> Owned by: adrian
Component: Core (Other) Version: master
Severity: Keywords: PYTHONSTARTUP
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Responding to this thread on Django Users: http://tinyurl.com/2rferr

This patch adds PYTHONSTARTUP capability to manage.py shell when:

  1. PYTHONSTARTUP is defined in the environment
  2. .pystartup is present in the user's home directory

Use of the --plain option disables execution of PYTHONSTARTUP.

Attachments (1)

pythonrc.diff (735 bytes) - added by Jeff Bauer <jbauer@…> 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Jeff Bauer <jbauer@…>

comment:1 in reply to: ↑ description Changed 7 years ago by Jeff Bauer <jbauer@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
<  2. .pystartup is present in the user's home directory
>  2. .pythonrc.py is present in the user's home directory

comment:2 Changed 7 years ago by Michael Radziej <mir@…>

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #3381.

Your patch looks a bit different, though. If your patch is a improvement to the other one, can you please share your ideas in the other ticket?

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.