Code

Opened 7 years ago

Closed 7 years ago

#3326 closed (fixed)

Timeline RSS feed broken

Reported by: Marc Fargas <telenieko@…> Owned by: nobody
Component: *.djangoproject.com Version: master
Severity: Keywords: sprintsept14
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Try this link: http://code.djangoproject.com/timeline?ticket=on&ticket_details=on&changeset=on&wiki=on&max=50&daysback=90&format=rss
It's the RSS feed for the timeline with all checkboxes marked (daysback=90 is set by TRAC)

It gives that:

Internal Error

Ticket changes, Ticket details event provider (TicketModule) failed:

AttributeError: 'NoneType' object has no attribute 'lower'

You may want to see the other kind of events from the Timeline

TracGuide — The Trac User and Administration Guide

Attachments (0)

Change History (9)

comment:1 Changed 7 years ago by Marc Fargas <telenieko@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Maybe it has something to do with the removal of the "defect"-"enhacement" selectbox, if you look at the timeline new tickets show as "(None)" where it previously said "(defect)" could that be the cause of the RSS feeds being broken?

comment:2 Changed 7 years ago by SmileyChris

  • Triage Stage changed from Unreviewed to Accepted

comment:3 Changed 7 years ago by SmileyChris

  • Triage Stage changed from Accepted to Ready for checkin

I'm not sure if we can write a patch, so I'll promote to ready for checkin for visibilty :)

comment:4 Changed 7 years ago by Marc Fargas <telenieko@…>

Nice trick :) Method two is refresh the RSS page until somebody notices the error.log.. hehe. The error only appears with "Ticket Details" chekbox and it's disabled by default so atleast there won't be much afected people, only the one that use it! :(

comment:5 Changed 7 years ago by jacob

  • Resolution set to wontfix
  • Status changed from new to closed

This is a bug in our version of Trac. I think I'm gonna hold off upgrading until 0.11 is final, so we'll just have to deal with this until then.

comment:6 Changed 7 years ago by cboos

  • Has patch set
  • Resolution wontfix deleted
  • Status changed from closed to reopened

I just noticed the '(None)' stuff on your timeline today, and fixed it.
You can safely apply trac 5821 on your 0.10.3 version.
Please don't hesitate to report such defects back to the Trac Project.

comment:7 Changed 7 years ago by Marc Fargas <telenieko@…>

  • Triage Stage changed from Ready for checkin to Accepted

Ahhh thanks!!! I will be able to subscribe again for RSS feeds!
hurrayyy!!!!!!!!!!

Hope jacob can apply the patch :)))))))))))

comment:8 Changed 7 years ago by Fredrik Lundh <fredrik@…>

  • Keywords sprintsept14 added
  • Triage Stage changed from Accepted to Ready for checkin

(Not sure you want to fix this during the sprint, though, given how much noise we're producing right now ;-)

comment:9 Changed 7 years ago by jacob

  • Resolution set to fixed
  • Status changed from reopened to closed

Yay, fixed - thanks, cboos!

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.