#31191 closed Cleanup/optimization (duplicate)

Fix the style guide to recommend `raise from`.

Reported by: Ram Rachum Owned by: nobody
Component: Documentation Version: dev
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Following Carlton Gibson's message here: https://github.com/django/django/pull/12339#pullrequestreview-345795699

I'd like to add a section to the style guide that requires the use of raise from when raising exceptions.

Change History (1)

comment:1 Changed 17 months ago by Mariusz Felisiak

Resolution: duplicate
Status: newclosed
Summary: Fix the style guide to recommend `raise from`Fix the style guide to recommend `raise from`.

Duplicate of #31177. This doesn't require a separate ticket.

Note: See TracTickets for help on using tickets.
Back to Top