Code

Opened 8 years ago

Closed 8 years ago

#2890 closed enhancement (fixed)

suggest default value for User.is_staff/is_superuser

Reported by: dummy@… Owned by: adrian
Component: Contrib apps Version: master
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I create user objects via 'User.objects.get_or_create(username=username)' and got SQL-warnings:

/usr/lib/python2.3/site-packages/django/db/backends/mysql/base.py:35: Warning: Incorrect integer value: for column 'is_staff' at row 1

return self.cursor.execute(sql, params)

/usr/lib/python2.3/site-packages/django/db/backends/mysql/base.py:35: Warning: Incorrect integer value: for column 'is_superuser' at row 1

return self.cursor.execute(sql, params)

I suggest default value 'False' for User.is_staff and User.is_superuser.

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by SmileyChris

Potentially a dupe of #2855, glad to see other people have a problem with this too. I'll leave this open for now though.

comment:2 Changed 8 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [3930].

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.