Opened 3 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#28819 closed Uncategorized (invalid)

Django 2.0 - subclasses of Loader must provide a get_template_sources() method

Reported by: kakulukia Owned by: nobody
Component: Uncategorized Version: 2.0
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by kakulukia)

Hi!

Im using pypugjs (https://github.com/matannoam/pypugjs) to have cleaner templates, but with 2.0 something is broken for me and im note sure what changed, because there is nothing serious in the release notes about the templating system and according to git the loaders/base.py was last touched in January this year.

So why would this break all of a sudden but still work with 1.11.7?
Can someone confirm that there is also a problem with other custom template loaders?

BTW: im using the following project template: https://github.com/kakulukia/django-default-project/ - just updating django to 2.0 inside there will trow the mentioned error.

Change History (3)

comment:1 Changed 3 weeks ago by kakulukia

Description: modified (diff)

comment:2 Changed 3 weeks ago by Tim Graham

Resolution: invalid
Status: newclosed

I answered on the pypugjs issue. In the future, please use our support channels to ask questions.

comment:3 Changed 3 weeks ago by kakulukia

okay .. its not a bug. I just didnt see deprecation warnings because they are disabled at least in 1.11 :)
good to know!

Note: See TracTickets for help on using tickets.
Back to Top