Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#27837 closed Bug (invalid)

After upgrade 1.4 to 1.8 in the database creats (or updates) mixed objects with old

Reported by: Grigoriy Kramarenko Owned by: nobody
Component: Uncategorized Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Hello!
In start of January, I updated two completely different project from version 1.4.22 to version 1.8.16.
In these two highload projects began to appear mixed objects (periodically).
They include some data from other objects, plus the new data.
Despite the fact that the code is almost unchanged, except for the announcement of the transactions.
Moreover, I tried to catch this bug before saving to the database, but nothing showed.
I suspect the problem in an permanent database connection and in the new transaction with the repetition of old objects.
It is just not in psycopg2, because the return on Django 1.4 - resolves this issue completely.
Please tell me how to configure Django to the old behavior with a PostgreSQL database and resolve this problem for the future.

Change History (5)

comment:1 Changed 21 months ago by Tim Graham

Resolution: invalid
Status: newclosed

Please see TicketClosingReasons/UseSupportChannels for ways to get help. If you've identified a bug in Django, then this is the appropriate place to report that. Without a way to reproduce your problem, it's unlikely you'll get useful help.

comment:2 Changed 21 months ago by Grigoriy Kramarenko

Tim,
thank you for what you easier to close the ticket as invalid, instead of having to delve into an awesome bug!!!!!!!!

comment:3 Changed 21 months ago by Grigoriy Kramarenko

Me and so hard to write in your language. I may not understand the requirements, and not well written, but that didn't lessen the problems with Django 1.8, which we have all hoped.

comment:4 Changed 21 months ago by Grigoriy Kramarenko

Tim, once again you ignore my attempts to help Django. I will assume that you are not in the right place...

comment:5 Changed 21 months ago by Aymeric Augustin

Grigoriy -- please don't pick on Tim -- no need to get personal here. Debugging your project isn't his job. It's yours. I understand that you're frustrated but please consider the following.

This isn't an awesome bug. This is a messy, random bug which may be in your code, in a third-party library you're using, or in Django. That's impossible to tell at this point.

Your description doesn't remind me of anything I ever heard of. If Tim had seen a similar report before, he would have said so. Since you're talking about fairly old versions, the lack of similar reports suggest that the bug is unlikely to be in Django itself. It may be in the way you're using it.

That said, the real problem is that I, Tim, or anyone else, have absolutely no way to reproduce your problem. I understand that you're seeing this issue. But how do you expect someone else to reproduce it, let alone diagnosing it without reproducing it?

In these two highload projects

This suggests you're only seeing the problem under your particular production load, which I don't know how to emulate.

began to appear mixed objects (periodically).

I have no idea what kind of operation could produce a "mixed" object, which makes it hard to write reproduction code.

If you can provide a piece of code that exhibits the issue and instructions to run it, then perhaps someone will be able to help. Reducing the issue to a reasonably small test case is your job here. I don't see how anyone else could do that with the information you've provided.

Unfortunately, this means we can't do anything with your report in its current state. For this reason Tim closed it. If you can provide additional information, then we'll be happy to reopen it.

I hope this clarifies the situation.

Note: See TracTickets for help on using tickets.
Back to Top