Code

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2766 closed defect (duplicate)

all of djangos decorators generating wrappers dont assign necessary attributes to the wrapper

Reported by: anonymous Owned by: adrian
Component: Core (Other) Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

the wrapped functions name, dict, module, and doc arent transfered to the wrapper function

this is very confusing and makes some stuff very hard

found the problem when i tried to add dynamic resolving of the base-url to my app by resolving the view for "/" with the apps urlconf and using its name + module to reverse-resolve the url for it

but the function was inner_func from django.decorators....

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by Gary Wilson <gary.wilson@…>

  • Resolution set to duplicate
  • Status changed from new to closed

Marking this a duplicate of #1840, there is more discussion there.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.