Opened 13 months ago

Last modified 13 months ago

#27450 new Bug

GDALBandTests.test_band_data test failure on MacOS 10.12.1 and python3.5

Reported by: Olivier Tabone Owned by: nobody
Component: GIS Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

failing test: test_band_data (gis_tests.gdal_tests.test_raster.GDALBandTests)

interestingly the test pass with python 2.7 on the same machine.

lib versions, installed with mac ports

  • gal 2.1.1
  • geos 3.6.0
  • python 3.5.2
======================================================================
FAIL: test_band_data (gis_tests.gdal_tests.test_raster.GDALBandTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.5/lib/python3.5/unittest/case.py", line 58, in testPartExecutor
    yield
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.5/lib/python3.5/unittest/case.py", line 600, in run
    testMethod()
  File "/Users/olivier/dev/sprints/django-olibook/tests/gis_tests/gdal_tests/test_raster.py", line 350, in test_band_data
    self.assertTrue(os.path.isfile(pam_file))
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.5/lib/python3.5/unittest/case.py", line 677, in assertTrue
    raise self.failureException(msg)
AssertionError: False is not true

----------------------------------------------------------------------

Change History (3)

comment:1 Changed 13 months ago by Saulius Žemaitaitis

Resolution: duplicate
Status: newclosed

Duplicate of #27399.

A work-around is to install Pillow from source instead of a wheel:

pip install --no-binary Pillow -r tests/requirements/py3.txt

comment:2 Changed 13 months ago by Saulius Žemaitaitis

Resolution: duplicate
Status: closednew

This is actually a different issue, sorry. It might be related to #27399 though.

comment:3 Changed 13 months ago by Tim Graham

Summary: GIS tests failure on MacOS 10.12.1 and python3.5GDALBandTests.test_band_data test failure on MacOS 10.12.1 and python3.5
Triage Stage: UnreviewedAccepted
Note: See TracTickets for help on using tickets.
Back to Top