Opened 5 years ago

Closed 5 years ago

#26326 closed Bug (worksforme)

Admin related object pop-ups not working

Reported by: maceo Owned by: nobody
Component: contrib.admin Version: 1.9
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Instead of opening in a pop-up the related object change form opens in a new window. After some investigation, the modification below has fixed it. One of you lovely Django peoples please verify/patch. Thank you.

+++ b/contrib/admin/templates/admin/related_widget_wrapper.html
@@ -10,7 +10,7 @@
         </a>
         {% endif %}
         {% if can_add_related %}
-        <a class="related-widget-wrapper-link add-related" id="add_id_{{ name }}"
+        <a class="related-widget-wrapper-link add-another" id="add_id_{{ name }}"
             href="{{ add_related_url }}?{{ url_params }}"
             title="{% blocktrans %}Add another {{ model }}{% endblocktrans %}">
             <img src="{% static 'admin/img/icon-addlink.svg' %}" alt="{% trans 'Add' %}"/>

Attachments (1)

Screenshot-Change user | Django site admin - Mozilla Firefox.png (93.1 KB) - added by maceo 5 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 5 years ago by Tim Graham

On which page are you opening the popup?

Are you running Django 1.9.3? A similar report was fixed in Django 1.9.1 (#25903).

comment:2 Changed 5 years ago by maceo

Change user > Permissions > Groups

The style of the link to add a new group is also affected by the fix. I will add a screenshot.

The version is 1.9.3 installed the day i posted via pip. The project has nothing on it except what was created by startproject

Last edited 5 years ago by maceo (previous) (diff)

comment:3 Changed 5 years ago by Tim Graham

Have you tried a different browser? I cannot reproduce a problem in Firefox or Chrome.

comment:4 Changed 5 years ago by Tim Graham

Easy pickings: unset
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.
Back to Top