Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#26137 closed Cleanup/optimization (fixed)

Document steps needed to install spatialite on Ubuntu 15.04+

Reported by: Tim Graham Owned by: nobody
Component: Documentation Version: master
Severity: Normal Keywords:
Cc: Claude Paroz Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I ran into a problem running the Django test suite with spatialite and found this solution on the blogosphere which worked for me:

If you updated recently to the last ubuntu version (15.10) and you're getting this error or similar:

Unable to load the SpatiaLite library extension "libspatialite.so.7" because: /usr/lib/x86_64-linux-gnu/libspatialite.so.7: undefined symbol: sqlite3_spatialite_init 

You can fix it adding this line to your settings.py file: SPATIALITE_LIBRARY_PATH = 'mod_spatialite'
... and installing a package: sudo apt-get install libsqlite3-mod-spatialite

Is the situation the same on newer versions of Debian? Is this something we should recommend?

Change History (3)

comment:1 Changed 4 years ago by Tim Graham

Has patch: set
Triage Stage: UnreviewedAccepted

I don't completely understand it, but it looks like mod_spatialite is required for spatialite 4.2+?

PR

comment:2 Changed 4 years ago by Tim Graham <timograham@…>

Resolution: fixed
Status: newclosed

In 93897a6:

Fixed #26137 -- Confirmed support for SpatiaLite 4.2/4.3 and added instructions.

comment:3 Changed 4 years ago by Tim Graham <timograham@…>

In d6d8fd3b:

[1.9.x] Fixed #26137 -- Confirmed support for SpatiaLite 4.2/4.3 and added instructions.

Backport of 93897a6a75754c1c17d8a60dee188c86f13de232 from master

Note: See TracTickets for help on using tickets.
Back to Top