Opened 5 years ago

Closed 5 years ago

#26091 closed Uncategorized (duplicate)

Django Installation on Ubuntu server 14.04.3

Reported by: Ali Kabiri Owned by:
Component: Error reporting Version: 1.9
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Ali Kabiri)

I get the following error while I try to install Django using pip.

sudo pip install django
Downloading/unpacking django
  Downloading Django-1.9.1-py2.py3-none-any.whl (6.6MB): 6.6MB downloaded
Installing collected packages: django
Compiling /tmp/pip_build_root/django/django/conf/app_template/apps.py ...
  File "/tmp/pip_build_root/django/django/conf/app_template/apps.py", line 1
    {{ unicode_literals }}from django.apps import AppConfig
                             ^
SyntaxError: invalid syntax

Compiling /tmp/pip_build_root/django/django/conf/app_template/models.py ...
  File "/tmp/pip_build_root/django/django/conf/app_template/models.py", line 1
    {{ unicode_literals }}from django.db import models
                             ^
SyntaxError: invalid syntax

Successfully installed django
Cleaning up...

Change History (2)

comment:1 Changed 5 years ago by Ali Kabiri

Description: modified (diff)

comment:2 Changed 5 years ago by Aymeric Augustin

Resolution: duplicate
Status: newclosed

Duplicate of #25992, #25990, #25960, #25901, #25885, #25625, #25584.

Note: See TracTickets for help on using tickets.
Back to Top