Opened 4 years ago

Closed 4 years ago

#25877 closed Cleanup/optimization (duplicate)

Consider refactoring AdminSite.check_dependencies

Reported by: Aymeric Augustin Owned by: nobody
Component: contrib.admin Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

I see two problems with this method:

  1. It doesn't take advantage of the checks framework. Perhaps it should?
  2. It runs as a side effect of loading the admin URLs. If it must run when Django starts it should be called from AdminAppConfig.ready() instead.

Change History (1)

comment:1 Changed 4 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #24116

Note: See TracTickets for help on using tickets.
Back to Top