Opened 8 years ago

Closed 8 years ago

#25810 closed Bug (wontfix)

verbose_name_plural is not respected in filter_horizontal or filter_vertical widget

Reported by: Jens-Erik Weber Owned by: nobody
Component: contrib.admin Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When using the filter_horizontal or filter_vertical widget in the admin section, verbose_name_plural should appear in the selection labels, but in fact only the class name in lower case appears.

In Ticket #14869 there was a report mentioning that verbose_name_plural appears in lower case, but that’s not case in the current version.

It also doesn’t matter what verbose_name is set to. So the problem is not mixing up singular and plural.

Change History (1)

comment:1 Changed 8 years ago by Tim Graham

Resolution: wontfix
Status: newclosed

The widget uses the field's verbose_name. Probably we shouldn't change this, if only for backwards compatibility reasons.

Note: See TracTickets for help on using tickets.
Back to Top