Opened 8 years ago

Closed 8 years ago

#25554 closed Uncategorized (duplicate)

Django permissions cause data migration depending on permissions to fail

Reported by: Dirk Uys Owned by: nobody
Component: Migrations Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I'm using a data migration to create a Group. Later I'm adding some permissions to a model and in a next migration I wish to assign those permissions to the group I created in another data migration.

Since permissions are only added to the database using the post_migrate signal, my migrations fail when trying to apply all of them at once. If I apply them 1 for 1, it doesn't fail since the permissions are created before running the next migrations

Change History (1)

comment:1 by Tim Graham, 8 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #23422

Note: See TracTickets for help on using tickets.
Back to Top