Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#25174 closed Cleanup/optimization (fixed)

Move some details of CheckMessage to the reference guide.

Reported by: Jack Laxson Owned by: nobody
Component: Documentation Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Jack Laxson)

https://docs.djangoproject.com/en/1.8/topics/checks/ doesn't say where django looks for these checks... it looks like checks.py is the right answer.

edit: So It appears that you need to hook the checks into django yourself? (e.g. via Appconfig) This seems like a high bar of entry but it needs to be documented better

Change History (6)

comment:1 Changed 7 years ago by Jack Laxson

Description: modified (diff)

comment:2 Changed 7 years ago by Tim Graham

I think it's documented pretty well in Registering and labeling checks, but feel free to suggest a patch if something is unclear.

comment:3 Changed 7 years ago by Baptiste Mispelon

The "Registering and labeling checks" section has the right information indeed but it's not that obvious that you should read it.

I think the problem is the reference documentation of CheckMessage that sits between the code example that uses @register without telling you where the code should live, and the paragraph that suggests you to put the code in an AppConfig.ready() method.
Personally, it made me switch between the "read as text, from top to bottom" mode (ie "topic-style" documentation) to the "hop around trying to find the info I'm looking for" mode (ie "reference-style" documentation).

Could we maybe move the bulk of the reference documentation for CheckMessage into the /ref/ documentation section?

comment:4 Changed 7 years ago by Tim Graham

Has patch: set
Summary: System Check documentation lacking locationMove some details of CheckMessage to the reference guide.
Triage Stage: UnreviewedAccepted
Type: UncategorizedCleanup/optimization

comment:5 Changed 7 years ago by Tim Graham <timograham@…>

Resolution: fixed
Status: newclosed

In faa2a0f:

Fixed #25174 -- Moved some details of CheckMessage to the reference guide.

comment:6 Changed 7 years ago by Tim Graham <timograham@…>

In 386a6dc3:

[1.8.x] Fixed #25174 -- Moved some details of CheckMessage to the reference guide.

Backport of faa2a0f662ed6fe0b90d10e98cc8ee3795d9307c from master

Note: See TracTickets for help on using tickets.
Back to Top