Opened 6 years ago

Closed 6 years ago

#24237 closed Bug (duplicate)

1.7.4 requires derived ManyToManyFields to declare their internal_type as "ManyToManyField" or their add/remove migrations will do nothing

Reported by: ris Owned by: nobody
Component: Migrations Version: 1.7
Severity: Normal Keywords: m2m migration add remove
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

According to the boffins on irc this is related to ticket #24104.

Using postgres and django 1.7.4, a custom ManyToManyField subclass that doesn't override the get_internal_type method will generate empty sql when a field add/removal migration is performed for it.

Whether or not this is desirable behaviour, it is *not* how 1.7.3 behaved and will potentially trip up a good number of people.

Change History (1)

comment:1 Changed 6 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #24236

Note: See TracTickets for help on using tickets.
Back to Top