Opened 10 years ago

Closed 9 years ago

#23700 closed Bug (fixed)

Non-deterministic static files test failures on Windows

Reported by: Tim Graham Owned by: nobody
Component: contrib.staticfiles Version: dev
Severity: Normal Keywords: windows-test-failure
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: yes
Easy pickings: no UI/UX: no

Description

Occasionally, ./runtests.py staticfiles_tests (or when running the entire test suite) will fail with PermissionError: [WinError 5] Access is denied errors. I believe the cause is related to 949ee521fab106b44218c30577eb55f0097d39cd. If I revert it, I've been unable to reproduce the failures.

Change History (3)

comment:1 by Michael Manfre, 10 years ago

Has patch: set
Patch needs improvement: set

The pull request only masks the problem of STATIC_ROOT not existing (or being inaccessible).

comment:2 by Tim Graham, 9 years ago

Keywords: windows-test-failure added

comment:3 by Tim Graham <timograham@…>, 9 years ago

Resolution: fixed
Status: newclosed

In b9feec959b9dfc08513607c9046fb38c5b8f7e8a:

Fixed #23700 -- Fixed non-deterministic static files test failures on Windows.

This partially reverts commit 949ee521fab106b44218c30577eb55f0097d39cd
refs #21230.

Note: See TracTickets for help on using tickets.
Back to Top