Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#23530 closed Bug (fixed)

yaml data files need PyYAML installed

Reported by: Alan Stebbens Owned by: nobody
Component: Documentation Version: 1.7
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In the documentation at Providing Initial Data, the format of a yaml file is described, but not that the PyYAML module needs to be also installed in order for the manage.py loaddata invocation to work. Apparently, it is not installed by default with django.

Just before the paragraph starting Loading data is easy .., the following should be added:

To make use of yaml files, the PyYAML module should be installed with pip install PyYAML, after which, loading data is easy.

Change History (2)

comment:1 Changed 9 years ago by Claude Paroz <claude@…>

Resolution: fixed
Status: newclosed

In 5bf654e44b7473a2a4c284d0a4c47585d19f3a46:

Fixed #23530 -- Specified PyYAML requirement in initial-data.txt

Thanks aks for the report.

comment:2 Changed 9 years ago by Claude Paroz <claude@…>

In 8a782571333f21e83980411301a0c8cc2d59a0b7:

[1.7.x] Fixed #23530 -- Specified PyYAML requirement in initial-data.txt

Thanks aks for the report.
Backport of 5bf654e44b7 from master.

Note: See TracTickets for help on using tickets.
Back to Top