Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#23390 closed Uncategorized (duplicate)

Clicking on the Add Group + in an Auth User's change-view results in a 400

Reported by: Michael Angeletti Owned by: nobody
Component: contrib.admin Version: 1.7-rc-3
Severity: Normal Keywords: auth, admin
Cc: Michael Angeletti Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Using Django 1.7c3 with everything default on a brand new project, I visited a user's change-view in the admin, clicked the + next to Groups (since there are none by default), and was taken to the following URL in a popup window: http://127.0.0.1:8000/admin/auth/group/add/?_to_field=id&_popup=1. The _to_field param causes Django to return a Bad Request (400) response.

Attachments (2)

bad-request.png (81.6 KB) - added by Michael Angeletti 4 years ago.
Django stable/1.7.x (1.7.1)
error.png (214.4 KB) - added by Michael Angeletti 4 years ago.
Django master (@f36ab2d)

Download all attachments as: .zip

Change History (10)

comment:1 Changed 4 years ago by Baptiste Mispelon

Resolution: duplicate
Status: newclosed

Hi,

The bug does appear on 1.7c3 but it's been fixed on the latest stable/1.7.x branch.

Bisecting points to 3cbb7590cb0ece38f665b516db30cd5a9431f8c8 so it looks like this issue is a duplicate of #23329.

If that's not the case, please reopen.

Thanks.

Changed 4 years ago by Michael Angeletti

Attachment: bad-request.png added

Django stable/1.7.x (1.7.1)

Changed 4 years ago by Michael Angeletti

Attachment: error.png added

Django master (@f36ab2d)

comment:2 Changed 4 years ago by Michael Angeletti

Hi @bmispelon,

I've just reproduced the issue on a different admin page (haven't tried on the User page) with Django stable/1.7.x (@267b121), as well as a different error with master. I've attached a screenshot of each, containing the URL and the result. I wasn't sure if it'd be appropriate to reopen the ticket that you marked this a duplicate as, since it appears the issue therein has been fixed, while this issue is maybe due to something different.

Thanks
Michael

Last edited 4 years ago by Michael Angeletti (previous) (diff)

comment:3 Changed 4 years ago by Michael Angeletti

Resolution: duplicate
Status: closednew

comment:4 Changed 4 years ago by Tim Graham

Can you check if #23431 solves your issue? If not, we'll need more details about your models, etc. so we can reproduce it.

comment:5 Changed 4 years ago by Simon Charette

Resolution: duplicate
Status: newclosed

I'm pretty confident this a duplicate of #23431 caused by the auto_created hidden relationship between User and Group.

comment:6 Changed 4 years ago by Michael Angeletti

@charettes @timgraham - #23431 did not solve the issue, as noted in my comment above.

comment:7 Changed 4 years ago by Tim Graham

#23431 was committed after your comment 2 days ago. Did you recheck since then? If so, please provide models to reproduce.

comment:8 Changed 4 years ago by Michael Angeletti

@timgraham

Thanks for the reply. The issue is indeed fixed. I really appreciate your last comment, because yes I had updated just a couple days before the commit was merged, apparently.

Michael

Note: See TracTickets for help on using tickets.
Back to Top