Code

Opened 8 years ago

Closed 7 years ago

#2292 closed enhancement (duplicate)

[patch] App-specific index pages for the admin system

Reported by: jkocherhans Owned by: cwebber
Component: contrib.admin Version: newforms-admin
Severity: normal Keywords:
Cc: aenor.realm@…, jkocherhans@…, gary.wilson@… Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: yes
Easy pickings: UI/UX:

Description

For sites with a lot of apps installed, the index page of the admin system can get pretty long. I propose (and I'm not the first) to add application specific index pages to Django's admin system. The template path for this page will be ('admin/myapp/app_index.html', 'admin/app_index.html') where myapp the is app_label part of the url. This page should be added to the breadcrumbs throughout the admin system as well.

Attachments (1)

app_specific_index.diff (15.7 KB) - added by jkocherhans 8 years ago.
patch againt [3534]

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by wiz

  • Cc aenor.realm@… added

comment:2 Changed 8 years ago by jkocherhans

  • Cc jkocherhans@… added

comment:3 Changed 8 years ago by anonymous

  • Cc gary.wilson@… added

comment:4 Changed 8 years ago by adrian

  • Status changed from new to assigned

Changed 8 years ago by jkocherhans

patch againt [3534]

comment:5 Changed 8 years ago by jkocherhans

This patch could still be improved via refactoring, and by using the new reverse url lookup stuff (not sure if it's finalized yet) but at least there's no more copy/pasted code. What would really make it clean is a nice interface for app/model metadata. If anyone has any specific nits to pick with this patch, I'll address them. Otherwise consider this submitted for inclusion.

comment:6 Changed 8 years ago by jkocherhans

I take the copy/paste part back. The admin/app_index.html template is pretty much just a slightly modified copy of admin/index.html. The reverse url stuff would provide a nice fix for that though.

comment:7 Changed 7 years ago by Simon G. <dev@…>

  • Patch needs improvement set
  • Triage Stage changed from Unreviewed to Design decision needed

For what it's worth, I like the idea, but if it is given a green-light, it'll need to be rewritten for the newforms version of admin

comment:8 Changed 7 years ago by jkocherhans

  • Version set to newforms-admin

comment:9 Changed 7 years ago by jkocherhans

  • Triage Stage changed from Design decision needed to Accepted

comment:10 Changed 7 years ago by cwebber

  • Owner changed from nobody to cwebber
  • Status changed from assigned to new

comment:11 Changed 7 years ago by brosner

  • Resolution set to duplicate
  • Status changed from new to closed

Marking this a duplicate of #1390 because the patch there is against newforms-admin and accomplishes the same thing.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.