Opened 3 years ago

Closed 3 years ago

#21542 closed Uncategorized (duplicate)

optparse is deprecated, use argparse instead

Reported by: donturner Owned by: nobody
Component: Documentation Version: 1.6
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

On the following page:

https://docs.djangoproject.com/en/dev/howto/custom-management-commands/

The command line example uses import optparse. The optparse module is deprecated as per: http://docs.python.org/2.7/library/optparse.html#module-optparse

Suggestion is to update the example to use argparse instead.

Change History (1)

comment:1 Changed 3 years ago by Tim Graham

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Resolution: duplicate
Status: newclosed

Duplicate of #19973

Note: See TracTickets for help on using tickets.
Back to Top