Code

Opened 8 months ago

Closed 8 months ago

#20904 closed Bug (fixed)

Test failure on Oracle: test_ticket_16885

Reported by: shai Owned by: nobody
Component: Database layer (models, ORM) Version: 1.4
Severity: Normal Keywords: oracle
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Running tests on the current updated stable/1.4.x branch:

ERROR: test_ticket_16885 (regressiontests.test_runner.tests.Ticket16885RegressionTests)
Features are also confirmed on mirrored databases.
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/django/django/tests/regressiontests/test_runner/tests.py", line 235, in test_ticket_16885
    DjangoTestSuiteRunner(verbosity=0).setup_databases()
  File "/home/django/django/django/test/simple.py", line 317, in setup_databases
    self.verbosity, autoclobber=not self.interactive)
  File "/home/django/django/django/db/backends/creation.py", line 271, in create_test_db
    load_initial_data=False)
  File "/home/django/django/django/core/management/__init__.py", line 150, in call_command
    return klass.execute(*args, **defaults)
  File "/home/django/django/django/core/management/base.py", line 249, in execute
    sys.exit(1)
SystemExit: 1

This is caused by trying to validate all the models where some models have a CharField as PK, but on Oracle these are reported by Django as null=True. This happens although the test explicitly tries to work on SQLite, regardless of settings.

Attachments (0)

Change History (2)

comment:1 Changed 8 months ago by timo

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

This test was removed in 1.5: ad47364dd324508e8332ea853da59772431398aa

The null pk issue was also fixed in 1.5: 584e2c03376895aeb0404cc1fcc1ad24dfdbc58e

Not sure the best way to address this for 1.4.

comment:2 Changed 8 months ago by Shai Berger <shai@…>

  • Resolution set to fixed
  • Status changed from new to closed

In d9dc98159d0454d74aebec3e9a763ddecea0961e:

[1.4.x] Fixed #20904: Test failure on Oracle
Just skip the failing test, the failure isn't really relevant; also,
both the test and the reason for its failure were removed in 1.5.

Thanks Tim Graham for advice on 1.5.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.