Opened 2 years ago

Closed 2 years ago

#20751 closed New feature (wontfix)

Add option to runfcgi to set socket permissions (also, tests for runfcgi)

Reported by: ntrrgc@… Owned by: nobody
Component: Utilities Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Even if it seems nobody loves FastCGI, here it is: A patch to add this long-missed feature. With documentation updates and unit tests.

The issue is discussed here: https://groups.google.com/forum/#!topic/django-developers/u4b-9rFIHts

Attachments (1)

0001-socketumask-argument-for-runfcgi-tests.patch (15.8 KB) - added by ntrrgc@… 2 years ago.
Patch

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by ntrrgc@…

Patch

comment:1 Changed 2 years ago by timo

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Duplicate of #14958 but I'll leave this one since it has a more extensive patch.

comment:2 Changed 2 years ago by timo

  • Resolution set to wontfix
  • Status changed from new to closed

Closing as "won't fix" since we are deprecating runfcgi. Perhaps this can be incorporated in the externally maintained successor to runfcgi if that happens.

Note: See TracTickets for help on using tickets.
Back to Top