Code

Opened 4 years ago

Closed 12 months ago

#14958 closed New feature (duplicate)

FastCGI socket permission

Reported by: joerg Owned by: nobody
Component: Core (Management commands) Version: 1.2
Severity: Normal Keywords: fastcgi
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Some systems like Linux want to apply the umask to Unix Domain Sockets. The current code only allows for fixing it afterwards or setting the umask for the whole process. Both is highly annoying, so the attached patch allows fixing it by using the corresponding flup option.

Attachments (2)

fastcgi.py.diff (947 bytes) - added by joerg 4 years ago.
socket_umask option
14958_fasctcgi_socket_umask.diff (1.1 KB) - added by dmclain 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by joerg

socket_umask option

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 3 years ago by anonymous

  • Severity set to Normal
  • Type set to New feature

comment:3 Changed 3 years ago by patchhammer

  • Easy pickings unset
  • Patch needs improvement set

fastcgi.py.diff fails to apply cleanly on to trunk

Changed 3 years ago by dmclain

comment:4 Changed 3 years ago by dmclain

  • Patch needs improvement unset

comment:5 Changed 2 years ago by aaugustin

  • UI/UX unset

Change UI/UX from NULL to False.

comment:6 Changed 16 months ago by aaugustin

  • Component changed from Core (Other) to Core (Management commands)

comment:7 Changed 12 months ago by timo

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20751 which has a more extensive patch.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.