Opened 2 years ago

Closed 2 years ago

#20676 closed Bug (fixed)

Wrong users highlighted as core devs in trac

Reported by: alexcouper Owned by: bmispelon
Component: * Version: 1.5
Severity: Normal Keywords:
Cc: bmispelon@… Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


I assigned a ticket to myself anonymously and was given Core status:

I've now reassigned it to a registered version of me and all is well.

Change History (5)

comment:1 Changed 2 years ago by bmispelon

  • Cc bmispelon@… added
  • Needs documentation unset
  • Needs tests unset
  • Owner changed from nobody to bmispelon
  • Patch needs improvement unset
  • Status changed from new to assigned
  • Summary changed from Trac gave Core dev status to Anon user to Wrong users highlighted as core devs in trac
  • Triage Stage changed from Unreviewed to Accepted

The highlighting of core developers is done client-side with javascript.

As it turns out, the regular expression used to detect usernames stops at whitespace so your username ends up being Alex, a username belonging to Alex Gaynor who is indeed a core developer.

I'll look into this and see if the regex can be fixed or if we need to change something in trac.


comment:2 Changed 2 years ago by aaugustin



comment:3 Changed 2 years ago by bmispelon

  • Has patch set

After digging a bit deeper into this issue, I'm starting to think the only sane fix would be to make everone named Alex a core developer...

The problem we have is that trac sometimes likes to use the full name of a user instead of his/her username when displaying a comment.
This means that we can't check reliably whether a user is a core dev or not.

I "improved" the username-extracting code to reject everything containing an "@" character.
This won't fix the core issue, but it should at least get rid of the false positives.

I hope you enjoyed your "core dev" highlight while it lasted ;)

comment:4 Changed 2 years ago by aaugustin

I applied the patch and I confirmed it fixes the issue.

comment:5 Changed 2 years ago by aaugustin

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.
Back to Top