Rename new checksetup manage command
|Reported by:||russellm||Owned by:||nobody|
|Component:||Core (Management commands)||Version:||master|
|Has patch:||no||Needs documentation:||no|
|Needs tests:||no||Patch needs improvement:||no|
Description (last modified by russellm)
In commit 91f317c7 Daniel committed a new management command called "checksetup" to perform warning-level checks for problems that may occur on upgrading between versions.
There is some overlap here between this new feature, and the scope of the 2013 GSoC project to refactor the "validate" command. One of the aims of this project is to reduce the naming collisions around "validate" -- it could refer to "form validation", "model validation" or "field validation", depending on how it's used.
This GSoC project will also involve the introduction of a new management command as part of reducing this naming collision; one of the candidate names was "check"
Before 1.6 is finalized, we should rename checksetup so it can be used as a generic command for all checks, rather than just the single-purpose check it's currently performing.
Change History (7)
comment:5 Changed 2 years ago by CollinAnderson
- Resolution fixed deleted
- Status changed from closed to new
comment:6 Changed 2 years ago by Tim Graham <timograham@…>
- Resolution set to fixed
- Status changed from new to closed