Code

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#2058 closed enhancement (duplicate)

Add read only permissions to views and fields to admin interface

Reported by: Rudolph Owned by: adrian
Component: contrib.admin Version: master
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

It would be nice to add read only permissions for every model. Then you could give certain users or groups the possibility to view an object in the admin interface without being able to change or delete it. One could just replace all input fields in a form by the value they have.

Another nice to have, is the possibility to make certain fields read only to users of the admin interface. E.g. a creation timestamp would be nice to see when you edit an object, but you are not allowed to edit it.

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #820.

comment:2 Changed 7 years ago by anonymous

  • milestone Version 1.0 deleted

Milestone Version 1.0 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.