Opened 23 months ago

Closed 23 months ago

Last modified 23 months ago

#20531 closed Cleanup/optimization (fixed)

Don't hard-code class names when calling static methods

Reported by: gwahl@… Owned by: nobody
Component: contrib.auth Version: 1.5
Severity: Normal Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


UserManager.normalize_email should be called on the instance, not the class. This has the same effect normally but is more helpful to subclassers. When methods are called directly on the class, subclasses can't override them.

Pull request:

Change History (2)

comment:1 Changed 23 months ago by Claude Paroz <claude@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 3d883e8bd96df8f2166aec6331b80781463539a6:

Merge pull request #1232 from fusionbox/normalize_email

Fixed #20531 -- Don't hard-code class names when calling static methods

comment:2 Changed 23 months ago by claudep

  • Component changed from Uncategorized to contrib.auth
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Ready for checkin
  • Type changed from Uncategorized to Cleanup/optimization
Note: See TracTickets for help on using tickets.
Back to Top