Code

#20325 closed Uncategorized (duplicate)

`--template` argument to `startapp` and `startproject` has incorrect help text.

Reported by: mrmachine Owned by: nobody
Component: Core (Management commands) Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

The help text says the --template argument on any TemplateCommand is the dotted import path to load templates from. Looking at the code and the docs reveals that this is not true. It is a local file system path that is passed through expanduser() and normpath(). The docs also use an HTTP URL to a GitHub zipball as an example.

Attachments (0)

Change History (1)

comment:1 Changed 12 months ago by mrmachine

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20256 -- Sorry folks!

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.