Opened 2 years ago

Closed 2 years ago

#20071 closed Cleanup/optimization (duplicate)

Remove widget display logic from database layer - ManyToMany model field

Reported by: gert314 Owned by: nobody
Component: Database layer (models, ORM) Version: 1.5
Severity: Normal Keywords: ManyToManyField help_text
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

The ManyToManyField (db/models/fields/related.py) concatenates this message to the field's help text:

'Hold down "Control", or "Command" on a Mac, to select more than one.'

If you use a different type of widget for a ManyToManyField the incorrect message is appended to the help text.

Clearly this does not belong in the database layer...

Change History (1)

comment:1 Changed 2 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14402 (yes, that ticket is a mess :-/).

Note: See TracTickets for help on using tickets.
Back to Top