Opened 2 years ago

Closed 2 years ago

#20033 closed Bug (duplicate)

Bug: collecstatic makes static files executable

Reported by: jon@… Owned by: nobody
Component: contrib.staticfiles Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The static files in my app directories have mode 0664. After calling ./manage.py collectstatic the collected static files have a mode of 0775. Why is the mode changed to executable? This seems incorrect and unintentional.

My app static directory: -rw-rw-r-- 1 jon jon 1614 Mar 7 14:07 base.css

My collected static directory: -rwxrwxr-x 1 jon jon 1614 Mar 12 12:11 base.css

Change History (1)

comment:1 Changed 2 years ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18947 (this was about uploaded files, but collectstatic uses the same code to copy files)

Note: See TracTickets for help on using tickets.
Back to Top