Code

Opened 8 years ago

Closed 8 years ago

#1983 closed defect (fixed)

Trac timeline RSS feed is broken

Reported by: Adam Endicott < > Owned by: jacob
Component: *.djangoproject.com Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Looks like the trac upgrade may have broken the RSS feed for the timeline (and possibly other things?)

The link from the bottom of the timeline page:

http://code.djangoproject.com/timeline?milestone=on&ticket=on&changeset=on&wiki=on&max=50&daysback=90&format=rss

just brings up an error page saying "Ticket changes event provider (TicketModule) failed: UnicodeDecodeError: 'utf8' codec can't decode byte 0xe5 in position 11: unexpected end of data"

...though I just realized there's a link on the error page that does work:

http://code.djangoproject.com/timeline?format=rss&max=50&daysback=90&milestone=on&changeset=on&wiki=on

which leaves out the "ticket=on" parameter, so maybe its not a Trac upgrade issue, but a bad character somewhere in one of the tickets?

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by adrian

I think it's a bad character somewhere in either a ticket or a wiki page, because a timeline page query over the same time range throws a similar error. Is anybody willing to click through tickets and wiki changes to try to isolate the error?

comment:3 Changed 8 years ago by Chris Rose <chris@…>

Ticket #9 would appear to be the cause of this problem.

comment:4 Changed 8 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed. Super-big thanks to Chris Rose for identifying the bad data.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.