Code

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#19757 closed Bug (fixed)

syncdb untranslated prompts for creating superuser

Reported by: eukreign Owned by: nobody
Component: contrib.auth Version: master
Severity: Release blocker Keywords:
Cc: apollo13 Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Using latest checkout of django-trunk with Python 2.7:

ubuntu:~/project$ ./manage.py syncdb
Creating tables ...
Creating table django_admin_log
Creating table auth_permission
Creating table auth_group_permissions
Creating table auth_group
Creating table django_content_type
Creating table django_session
Creating table account_user_groups
Creating table account_user_user_permissions
Creating table account_user

You just installed Django's auth system, which means you don't have any superusers defined.
Would you like to create one now? (yes/no): yes
<django.utils.functional.proxy object at 0x9a41dec>:

the prompts of username, email, password are displayed as proxy objects instead of translated strings.

Attachments (0)

Change History (3)

comment:1 Changed 17 months ago by eukreign

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Actually, looks like the password is fine, it's just the username and email that are not being translated:

ubuntu:~/project$ ./manage.py syncdb
Creating tables ...
Creating table django_admin_log
Creating table auth_permission
Creating table auth_group_permissions
Creating table auth_group
Creating table django_content_type
Creating table django_session
Creating table account_user_groups
Creating table account_user_user_permissions
Creating table account_user

You just installed Django's auth system, which means you don't have any superusers defined.
Would you like to create one now? (yes/no): yes
<django.utils.functional.proxy object at 0x9a41dec>: lex
<django.utils.functional.proxy object at 0x9ac32ec>: lex@…
Password:
Password (again):
Superuser created successfully.
Installing custom SQL ...
Installing indexes ...
Installed 0 object(s) from 0 fixture(s)

comment:2 Changed 17 months ago by ptone

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed with https://github.com/django/django/commit/2390fe3f4f8f52e24157d79b0c60247207c9716f

if you can reproduce with a checkout later than that version - please do reopen.

comment:3 Changed 17 months ago by Florian Apolloner <florian@…>

In 2b916895a1cea39de3280a6910e2886aebfcfc64:

Updated createsuperuser to use unicode_literals. Refs #19757.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.