Opened 4 years ago

Closed 16 months ago

#19429 closed Bug (fixed)

Admin inlines readonly fields ignore newlines

Reported by: anonymous Owned by: nobody
Component: contrib.admin Version: 1.8
Severity: Normal Keywords:
Cc: glic3rinu Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

like bug #19226 but with inlines.

The problem is readonly fields in inlines are rendered inside a <p></p> without <br> tags for each line.

Attachments (1)

ticket_19429.diff (1.8 KB) - added by glic3rinu 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by glic3rinu

comment:1 Changed 4 years ago by glic3rinu

  • Cc glic3rinu added
  • Component changed from Uncategorized to contrib.admin
  • Easy pickings set
  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Ready for checkin
  • Type changed from Uncategorized to Bug

comment:2 Changed 4 years ago by glic3rinu

The attached patch fixes the problems and also has tests.

comment:3 Changed 4 years ago by Claude Paroz <claude@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 553838a285d6ef4005d7a97fc07aebfb0dcdb921:

Fixed #19429 -- Applied linebreaksbr to read-only fields in inlines

Applied to inlines what ec9d6b1122d did for main fieldsets.

comment:4 Changed 4 years ago by Claude Paroz <claude@…>

In 57a41d985acabc7fc25f08081e58f0978cc8c1dc:

[1.5.x] Fixed #19429 -- Applied linebreaksbr to read-only fields in inlines

Applied to inlines what ec9d6b1122d did for main fieldsets.
Backport of 553838a28 from master.

comment:5 Changed 16 months ago by mthvth

  • Resolution fixed deleted
  • Status changed from closed to new
  • Version changed from 1.4 to 1.8

I had the same issue in 1.8 . A quick inspection of the source code revealed that the problem is exactly the same. The original patch is applicable to the version 1.8

Last edited 16 months ago by mthvth (previous) (diff)

comment:6 Changed 16 months ago by timgraham

  • Resolution set to fixed
  • Status changed from new to closed

In 1.8, the implementation has changed, see c94bff2b26f8844fe15d68a79511ff3a6853dc61. If you think that patch is incorrect, please open a new ticket. Thanks.

Note: See TracTickets for help on using tickets.
Back to Top