Opened 3 years ago

Closed 3 years ago

#19383 closed New feature (duplicate)

load_class to django utils

Reported by: ebertti Owned by: nobody
Component: Core (Other) Version: master
Severity: Normal Keywords: utils import
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: yes
Easy pickings: no UI/UX: no


One more helper to django utils.

This method is use by a lot of django-users, and is always re coded for every one, this can help a lot of developers.

Change History (2)

comment:1 Changed 3 years ago by aaugustin

  • Easy pickings unset
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement set
  • Triage Stage changed from Unreviewed to Accepted

This doesn't have to be class-specific; you can use the same code to load anything by name.

I think another ticket was created for this recently, but I can't find it.

If you're adding that function to Django, please use in wherever Django import things by "dotted path".

comment:2 Changed 3 years ago by aaugustin

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17061 which has a more complete patch.

Note: See TracTickets for help on using tickets.
Back to Top