Code

#19339 closed Bug (needsinfo)

Spatial Query in geodjango

Reported by: anjusb712@… Owned by: nobody
Component: GIS Version: 1.4
Severity: Normal Keywords: geodjango
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by claudep)

I am newbie in using geodjango, I need to check whether a point is present in a multipolygon layer. For trial I used

x = '640744.97964' 
y = '2498614.18957' 
p = Point(float(x), float(y), srid=32645) 
pt=layer.objects.get(the_geom__contains=p)

but I got the error NoneType object has no attribute 'group'

Attachments (0)

Change History (1)

comment:1 Changed 17 months ago by claudep

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to needsinfo
  • Status changed from new to closed

Without more details about your model and a traceback, we won't be able to determine if the problem is in Django itself.

I'd suggest you use support channels first, then reopen if you can show us there is a bug in Django.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.