Opened 3 years ago

Closed 3 years ago

#19288 closed Bug (invalid)

incorrect default verbose_name_plural in 1.5

Reported by: cdestigter Owned by: nobody
Component: Database layer (models, ORM) Version: 1.5-alpha-1
Severity: Release blocker Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Sometime since 1.5a1, MyModel._meta.verbose_name_plural seems to be set to a weird default:

from django.db.models.loading import get_models
for cls in get_models():
    print cls._meta.verbose_name_plural

<django.utils.functional.__proxy__ object at 0x25a3090>
<django.utils.functional.__proxy__ object at 0x25a62d0>
...

Overriding it via adding a Meta class on the model it works as expected. But the default is a little puzzling.

Marking as release blocker since this appears to be a regression in 1.5.

Change History (1)

comment:1 Changed 3 years ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

I find the exact same behaviour in 1.4. Reopen if you can demonstrate the regression.

Note: See TracTickets for help on using tickets.
Back to Top