Opened 3 years ago

Closed 3 years ago

#19286 closed Uncategorized (duplicate)

Development version is up to (1, 6, 0, 'alpha', 0) and 1.6 is intended to support python 3, so the tutorial should mention differences when using python 3

Reported by: colinnkeenan@… Owned by: nobody
Component: Documentation Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


My installation of Django shows django.VERSION as (1, 6, 0, 'alpha', 0). I'm doing everything with the python3 command in Ubuntu 12.10 instead of python, so in other words, I'm using python-3.2

In going through the polls tutorial, the __unicode__() method wasn't working. I eventually realized (by asking on that when using python 3, there isn't any __unicode__ method since the __str__ method now supports unicode by default.

The development version of the tutorial should be updated to mention that with python 3, you would just use __str__ as usual and that __unicode__ is not necessary and in fact won't even work.

Change History (1)

comment:1 Changed 3 years ago by charettes

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19211

Note: See TracTickets for help on using tickets.
Back to Top