Code

#19267 closed Bug (fixed)

Table of Contents missing and links broken in PDF on readthedocs

Reported by: michael.amie@… Owned by: nobody
Component: Documentation Version:
Severity: Normal Keywords: PDF, Documentation, Links
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In the 1.4.X series of documentation PDFs the content has been rearranged in such a way that the Table Of Contents does not specify which chapter / section # a given topic is located and the table of contents links are also broken, this makes navigating the documentation difficult.

Attachments (0)

Change History (7)

comment:1 Changed 18 months ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

It's strange that 1.3.x and dev seem to be fine, and not 1.4.x. I don't see what is so different in 1.4.x. Any hint? Or might this be simply a build failure on readthedocs?

comment:2 Changed 17 months ago by aaugustin

  • Triage Stage changed from Unreviewed to Accepted

Indeed.

comment:3 Changed 17 months ago by timo

This may be a problem with readthedocs -- I just rebuilt the docs for 1.3.X, 1.4.X, and latest there and now the TOC doesn't appear on any of them. However, when I build the docs locally (tested master and 1.4.X) the TOC does appear.

comment:4 Changed 17 months ago by aaugustin

I discussed on IRC with the maintainer of ReadTheDocs.

PDFs are generated via LaTeX, which tends to spit interesting but barely usable logs.

He thinks the issue is worth investigating, so let's keep this ticket open.

The fix may be purely on ReadTheDocs' side, and it may require fixes to Django's docs.

comment:5 Changed 16 months ago by timo

  • Summary changed from 1.4.1 PDF Table of Contents links broken to PDF Table of Contents missing on readthedocs
  • UI/UX unset
  • Version 1.4 deleted

comment:6 Changed 15 months ago by timo

  • Summary changed from PDF Table of Contents missing on readthedocs to Table of Contents missing and links broken in PDF on readthedocs

#19644 reported that all links point to the menu page which I think is the same root cause as this issue.

It looks like 'django.aux' isn't being generated for the readthedocs build.

I found the following note which may be relevant: "When using \label, you'll have to compile your LaTeX code twice. The first compilation will produce a .aux file that contains all the label information based on your \label commands. The second compilation reads and uses that information to fill out your \ref and \pageref commands."

comment:7 Changed 13 months ago by timo

  • Resolution set to fixed
  • Status changed from new to closed

Table of contents is back.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.