Code

#19240 closed Bug (fixed)

ListView pagination error does not expose specific InvalidPage exception message in 404.

Reported by: seawolf Owned by: seawolf
Component: Generic views Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

When viewing a generic list page with pagenate_by set, several exceptions can be thrown that inherit from InvalidPage in the case of a 404 error. However, the 404 page simply states "Invalid page (1).", which does not give the developer anything useful to help with figuring out what the source of the problem is.

Should this actually return a 500 error?

Attachments (1)

19240.diff (2.0 KB) - added by seawolf 18 months ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 18 months ago by seawolf

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

working on a test and fix ATM

Changed 18 months ago by seawolf

comment:2 Changed 18 months ago by seawolf

  • Has patch set

comment:3 Changed 18 months ago by seawolf

  • Component changed from HTTP handling to Generic views
  • UI/UX unset
  • Version changed from 1.5-alpha-1 to master

comment:4 Changed 18 months ago by Preston Holmes <preston@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 5a00a57aa591c766f5ee1d8c59b64618d74fe191:

Fixed #19240 -- include pagination error details in ListView 404

Thanks to seawolf for the patch

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.