Opened 3 years ago

Closed 3 years ago

#19048 closed Bug (duplicate)

[Management commands] Unknown commands on python packages application

Reported by: Natim Owned by: nobody
Component: Core (Management commands) Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


We are using the python namespace package functionality for a django project.


But the commands not in the project package (the one with are not found by the commands.

Attachments (1)

django_core_management_find_management_module.patch (1.0 KB) - added by Natim 3 years ago.
Patch to look at all pkg_resources

Download all attachments as: .zip

Change History (4)

comment:1 Changed 3 years ago by Natim

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

It seams to come from this which call imp.find_module('django_project')

This command, return the first pkg_module path and not all of them.

comment:2 Changed 3 years ago by Natim

Changed 3 years ago by Natim

Patch to look at all pkg_resources

comment:3 Changed 3 years ago by claudep

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8280

Note: See TracTickets for help on using tickets.
Back to Top