Code

Opened 22 months ago

Closed 21 months ago

Last modified 21 months ago

#19023 closed Bug (fixed)

Bug tracker spam filter is broken.

Reported by: tdhutt@… Owned by: aaugustin
Component: *.djangoproject.com Version:
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I just created a new ticket, and the spam filter is broken in at least 3 ways:

  1. It marked my message as spam when it very obviously wasn't.
  2. It asked me to "respond to the following." which was presumably meant to be followed by a captcha, but there wasn't actually anything to respond to.
  3. I clicked "back" and resubmitted the form and it worked! Surely if it thinks I am a spammer and can't answer the (non-existant) captcha I shouldn't be allowed to do that?

Attachments (0)

Change History (5)

comment:1 Changed 21 months ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for the report. The core team is aware of the problem: Trac's spam filter isn't fantastic.

However, we don't have a better alternative, and we prefer to keep it possible to contribute without creating an account.

And we focus our energy on improving Django rather than improving Trac :)

I recommend to create an account; you'll hardly ever encounter the spam filter when you're logged in.

Last edited 21 months ago by aaugustin (previous) (diff)

comment:2 Changed 21 months ago by aaugustin

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Erm, it appears I spoke too fast. The spam plugin is really broken. This may be a consequence of the upgrade to Trac 1.0.

comment:3 Changed 21 months ago by aaugustin

  • Owner changed from nobody to aaugustin
  • Status changed from reopened to new

comment:4 Changed 21 months ago by aaugustin

  • Triage Stage changed from Unreviewed to Accepted
  • Type changed from Uncategorized to Bug
  • Version 1.4 deleted

comment:5 Changed 21 months ago by aaugustin

  • Resolution set to fixed
  • Status changed from new to closed

The problem is that code.djangoproject.com uses HTTPS, but reCaptcha is served over HTTP, and browsers refuse to load mixed content.

I've resolved this problem by switching to a different captcha.

Last edited 21 months ago by aaugustin (previous) (diff)

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.