Opened 3 years ago

Closed 3 years ago

#18623 closed Bug (invalid)

RSS feeds specify Atom namespace

Reported by: djangoproject@… Owned by: nobody
Component: contrib.syndication Version: 1.4
Severity: Normal Keywords: rss atom
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no


All feeds generated using django.util.feedgenerator specify the Atom namespace in the root node, including Rss201rev2Feed and RssUserland091Feed. For example, when feed_type is specified as Rss201rev2Feed, django outputs as its root node: <rss xmlns:atom="" version="2.0">

Change History (5)

comment:1 Changed 3 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

The offending line was added in c4c27d8a04c9125cfbc5c3611557d8e5d3845b0d.

It was a large commit; this small regression probably went unnoticed.

comment:2 Changed 3 years ago by anonymous

Line 229 also uses atom namespace for item links in the base RssFeed class:

comment:3 Changed 3 years ago by namn

  • Keywords rss atom added
  • Triage Stage changed from Accepted to Design decision needed

There is a note in 1.2 release notes (in that same commit) that says atom:link is now a best practice in RSS.

In accordance with `RSS best practices`_, RSS feeds will now include
an ``atom:link`` element. You may need to update your tests to take
this into account.

The original document at says:

The Atom syndication format, which serves a similar purpose to RSS, offers some elements closely comparable to RSS elements and others that provide new capabilities. Any of these elements can be used in RSS by employing Atom as a namespace.

So, I guess having atom namespace in RSS feeds is okay because (quoted from the same document):

The RSS specification encourages the extension of the format through the use of namespaces.

Should this ticket be marked invalid?

comment:4 Changed 3 years ago by bfirsh

(Author of that commit here!) Yep - this should probably be marked as invalid. It is intentional for the reason namn pointed out.

comment:5 Changed 3 years ago by aaugustin

  • Resolution set to invalid
  • Status changed from new to closed

Thanks for your feedback!

Note: See TracTickets for help on using tickets.
Back to Top