Opened 3 years ago

Closed 3 years ago

#18462 closed Bug (duplicate)

UnicodeDecodeError in sql debug logger

Reported by: renato@… Owned by: nobody
Component: Core (Other) Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I get a UnicodeDecodeError in line 51 of db/backends/util.py whenever I try to save content with diacriticals in the admin interface. I don't know the correct way to fix this, but if I simply comment out the corresponding line it works:

# logger.debug('(%.3f) %s; args=%s' % (duration, sql, params), extra={'duration': duration, 'sql': sql, 'params': params})

Change History (1)

comment:1 Changed 3 years ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18461

Note: See TracTickets for help on using tickets.
Back to Top