Code

Opened 2 years ago

Closed 2 years ago

#18126 closed Uncategorized (duplicate)

Multithreaded Django runserver is not documented in 1.4 release notes

Reported by: onyxfish Owned by: nobody
Component: Documentation Version: 1.4
Severity: Normal Keywords:
Cc: valhallasw@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

I stumbled across the new --nothreading option. It says to read more in the release notes, but this isn't mentioned in the release notes. This really tripped me up when a threading bug appeared in development code where I did not think such a thing was possible.

https://docs.djangoproject.com/en/dev/ref/django-admin/#django-admin-option---nothreading

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by valhallasw

  • Cc valhallasw@… added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

This really should be added to the release notes -- the server fails with too many concurrent connections, and new connections are RST'ed. ("apr_socket_recv: Connection reset by peer (104)" according to ab - the nginx running in front returned 502's to the browser). Running the server with --nothreading means everything works as it did before. As this was not noted in the release notes, it took me an hour or two to find out what was causing this.

comment:2 Changed 2 years ago by akaariai

  • Resolution set to duplicate
  • Status changed from new to closed

I guess it is too late to change the default, so adding a note about this to release notes seems like the correct way forward.

I will close this as duplicate of #17997.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.