Opened 3 years ago

Closed 3 years ago

#17907 closed Uncategorized (duplicate)

"Something's wrong with your database installation" error message in DEBUG mode.

Reported by: anonymous Owned by: nobody
Component: contrib.admin Version: master
Severity: Normal Keywords:
Cc: dhepper Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In django/contrib/admin/options.py line 1131, a IncorrectLookupParameter exception is caught and the following error message is returned:

"Something's wrong with your database installation. Make sure the appropriate database tables have been created, and make sure the database is readable by the appropriate user."

IMHO, the exception should be reraised if settings.DEBUG is True.

The error message is to general to find the cause of the error. In my case, I had a bug in a SimpleListFilter subclass, which I could only find by setting a breakpoint in the Django code.

Attachments (1)

invalid_setup_patch.diff (769 bytes) - added by dhepper 3 years ago.

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by dhepper

comment:1 Changed 3 years ago by dhepper

  • Cc dhepper added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 3 years ago by aaugustin

  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate of #17828.

Note: See TracTickets for help on using tickets.
Back to Top